Storage | Singapore incident details
Incident Report for G-Core Labs
Resolved
This incident has been resolved.
Posted May 04, 2021 - 07:20 UTC
Investigating
We are currently experiencing perfomance's degradation
During this time, service may be unavailable for users
We apologize for any inconvenience it may cause. We will share an update once we have more information.
Posted May 04, 2021 - 06:32 UTC
This incident affected: Storage (SFTP Singapore).